Compilando Squid 4.6 desde código fuente

Soporte básico necesario: # apt install arj bzip2 xz-utils cabextract cpio file lzma lhasa lzop rpm2cpio gzip nomarch \ pax lzop rar unrar unzip zoo unace razor pyzor tnef ripole zip xz-utils lzma p7zip-full mc \ multitail ccze Instalar binarios necesarios para compilar Squid4: # apt install logrotate acl attr autoconf bison nettle-dev build-essential libacl1-dev…

Ejabberd + Samba4 + Shared Roster

De WIkipedia: Ejabberd es un servidor de mensajería instantánea de código abierto (GNU GPL) para plataformas Unix (BSD, GNU/Linux, etc), Microsoft Windows y otras. Para la comunicación instantánea se utiliza XMPP y está escrito principalmente en Erlang.Consume menos RAM que OpenFire, lo cual lo hace perfecto para el objetivo que se nos propone, instalar un…

Error «no valid subscription» en Proxmox 5.3

Para fixear este error y que no moleste más hagamos lo siguiente: ssh root@server-proxmox Nos logueamos y ejecutamos: cd /usr/share/javascript/proxmox-widget-toolkit cp proxmoxlib.js{,.bckp} Backup ante todo! Editamos el archivo proxmoxlib.js, dejándolo de la siguiente manera: Comentamos todo el bloque que chequea el estado de la subscripción y validamos directamente. Otra manera: sed -i.bak «s/data.status !== ‘Active’/false/g»…

Squid + Samba4, parte 1

Ante todo tengamos claro el esquema IP de las máquinas implicadas: 10.10.1.4 -> ADDC 10.10.1.5 -> PROXY Lo primero que haremos, en el ADDC, es crear un usuario que consultará al ADDC desde el Squid. Ejecutar lo siguiente en el servidor PDC Samba4: samba-tool user create squid –description=»User for Squid proxy server» –random-password samba-tool user…

Gracias EMOTET

EMOTET es un virus que afecta el correo electrónico, de forma singular. Viene enmascarado en forma de documento, con los posibles nombres de: «Factura», «Recibo de Factura», o «Factura TM-591.doc», el cual, si es abierto por un usuario que no conoce este virus, compromete su libreta de direcciones, donde el propio virus se auto-envía a…

«Release file expired», como arreglar este error #TIP

A veces cuando estamos trabajando con algún sistema y por alguna razón, al actualizar con algún repositorio local nos da este error: E: Release file expired, ignoring http://10.10.1.253/debian/stretch/dists/stretch/Release (invalid since 10h 45min 12s) Qué hacemos? Primero que todo, respirar hondo… Segundo, darnos cuenta que debemos actualizar nuestro repositorio local o hacer el siguiente tip, que…